Honorlock Support Volume

Incident Report for Honorlock

Resolved

At this time, our support volume has returned back to normal levels.
Posted Sep 10, 2020 - 20:56 EDT

Investigating

At this, we’re experiencing higher than normal chat volume and our team’s response will be delayed.  We will update this post as we have additional information.
Posted Sep 10, 2020 - 20:29 EDT
This incident affected: Support.