Issues with making payments.
Incident Report for Honorlock
Resolved
This incident has been resolved.
Posted Jun 13, 2024 - 19:59 EDT
Investigating
We have received several reports of issues when attempting to make payments and are raising the issue with our third party provider. Support agents are available to help; however, their response may be delayed due to the high amount of volume generated from this issue. We appreciate your patience.
Posted Jun 13, 2024 - 19:19 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, and Aleks Proctoring.