Honorlock Phones Unavailable - Our Provider Service is Currently Experiencing Downtime
Incident Report for Honorlock
Resolved
Our service provider has reestablished service. They have provided us with an update that the issue is 100% resolved. At this time our support center is taking phone calls again! You may resume contacting Honorlock support via phone.
Posted Nov 07, 2019 - 22:45 EST
Identified
Honorlock phones are currently unavailable. Our service provider is currently experiencing an issue. In the mean time you can still chat with our team directly from your exam or by going to https://honorlock.com/support to start a chat. We will update our status once our phone provider updates us that functionality has been restored.
Posted Nov 07, 2019 - 22:28 EST
This incident affected: Support.