Honorlock Service Outage

Incident Report for Honorlock

Resolved

This incident has been resolved.
Posted Jun 13, 2026 - 21:01 EDT

Monitoring

A fix has been implemented and we have received reports of improvements. We will continue to monitor the situation.
Posted Jun 13, 2026 - 20:44 EDT

Investigating

We are investigating reports of disruptions to the proctoring service and 504 timeout errors. Exam takers may be unable to load, navigate, or resume their exam.
Posted Jun 13, 2026 - 20:39 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, and Aleks Proctoring.