Honorlock.com/Install error
Incident Report for Honorlock
Resolved
This incident is resolved. Students can now download the extension from honorlock.com/install successfully.
Posted May 30, 2020 - 10:28 EDT
Identified
We have identified an issue with our Honorlock Extension Install page (honorlock.com/install) that is preventing students from being able to install the Honorlock Extension successfully. For the time being, please have students use the direct chrome store link to install the extension: https://chrome.google.com/webstore/detail/honorlock/hnbmpkmhjackfpkpcbapafmpepgmmddc

After installing the extension, students can proceed directly to their quiz to start their exam.
Posted May 30, 2020 - 08:47 EDT