Chrome Web Store Issues
Incident Report for Honorlock
Resolved
This incident has been resolved.
Posted May 29, 2024 - 17:49 EDT
Monitoring
Google Chrome Store services appear to be restored. Users are now reporting success when attempting to install extensions.
Posted May 29, 2024 - 17:21 EDT
Identified
We’ve received reports that some users are having trouble installing the Honorlock Extension. This appears to be an issue with the Google Chrome store. We are closely monitoring the situation and will update our status page accordingly.
Posted May 29, 2024 - 16:37 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, and Aleks Proctoring.