Sporadic Issues with Chat Support
Incident Report for Honorlock
Resolved
Our chat provider is reporting that this incident is now resolved.
Posted Mar 04, 2021 - 11:25 EST
Investigating
Our chat provider is currently experiencing an incident. Due to this, students may experience sporadic issues contacting our support team via chat. We are working directly with our chat provider to resolve this issue as quickly as possible. If you need support assistance and the chat option is not working for you, please email support@honorlock.com.
Posted Mar 04, 2021 - 10:45 EST
This incident affected: Support.