Chat Support Unavailable
Incident Report for Honorlock
Resolved
Chat support is now available.
Posted Mar 15, 2022 - 05:46 EDT
Investigating
Our chat support provider is currently investigating an issue that is impacting our ability to deliver chat support. Due to this, we are unable to answer support chats at this time. We are working directly with our chat provider to resolve this issue as quickly as possible. If you need urgent support assistance, please email support@honorlock.com and we will respond as soon as possible.
Posted Mar 15, 2022 - 05:18 EDT
This incident affected: Support.