Service Outage - 504 Timeout Errors

Incident Report for Honorlock

Resolved

This incident has been resolved. All services have been restored.
Posted Sep 14, 2025 - 21:44 EDT

Monitoring

Our engineering team has confirmed that services have been restored; however, some users may still be impacted. A refresh/reload of the webpage or relaunching of proctoring should correct any current problems. Our engineering team will continue to monitor the situation for the time being.
Posted Sep 14, 2025 - 21:39 EDT

Identified

We have identified the issue and have implemented a fix.
Posted Sep 14, 2025 - 21:34 EDT

Investigating

We have received reports of 504 gateway errors and our engineering team is currently invesitgating the cause.
Posted Sep 14, 2025 - 21:14 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, Aleks Proctoring, Honorlock Application, and Third-party Platform Proctoring.