Chat Support Unavailable
Incident Report for Honorlock
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 04:26 EDT
Identified
Our support chat provider is currently experiencing an outage. Due to this, we are unable to answer support chats at this time. We are working directly with our chat provider to resolve this issue as quickly as possible. If you or your students need support assistance, please email support@honorlock.com.
Posted Jul 25, 2022 - 04:00 EDT
This incident affected: Support.