Exam Start Delays
Incident Report for Honorlock
Resolved
This incident is now resolved. Students are now able to start their exams as normal.
Posted May 19, 2020 - 15:21 EDT
Investigating
We are currently investigating reports of students being unable to start their exam. At this time, we would recommend students start their exam at a later time. Exams that are in progress will continue to be monitored. We are actively investigating and will update this post once more information is available.
Posted May 19, 2020 - 15:08 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, Aleks Proctoring, and Third-party Platform Proctoring.