Honorlock Services affected by AWS Outage

Incident Report for Honorlock

Resolved

AWS has confirmed this issue has been resolved through their status page.
Posted Oct 20, 2025 - 07:00 EDT

Monitoring

As of 3:11 am EST, Amazon Web Services reported increased error rates and latencies in the US-EAST-1 Region. These services prevented some exam takers from starting or continuing their exam, and access to their LMS was sporadically prevented. The majority of AWS services were restored at approximately 6:03 am EST, and they are currently monitoring the situation.
Posted Oct 20, 2025 - 06:42 EDT
This incident affected: Canvas Proctoring, Blackboard Proctoring, D2L Proctoring, Aleks Proctoring, and Third-party Platform Proctoring.